[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mdadm not starting at boot



you know I had/have the same problem ...

I finally broke down and wrote my own init script that I run in
runlevels 2-5 that basically has 

mdadm -A -s
vgscan
vgchange -A y

And then my mounts in it ... I run it as an S19 so it starts right
before Samba and NFS which are what my raid array exports.

As for the bad superblock, it could be a hardware problem, or it could
be the power issues you've had ... if it persists even with clean
shutdowns, I'd start looking at the hardware.   Hope that helps.

H

On Thu, Dec 08, 2005 at 02:42:55AM -0500, Hal Vaughan wrote:
> I have two systems, both freshly installed Sarge systems, both with a RAID 5 
> array (3 drives plus a spare each).  One is working perfectly.  The other has 
> a problem whenever it boots (and I've had a number of power failures lately).  
> When the system boots, the RAID is not started.  I have to run mdrun to start 
> the RAID.  Once it's started, when I try mounting it, I always get a message 
> that it has a bad superblock.  I have to run fsck, which fixes it, and then I 
> can mount it and it works fine.
> 
> I tried dpkg-reconfigure and specifically told it to start on boot and to 
> start the monitor on boot, but that hasn't helped.  This array, when running, 
> is a 290GB RAID, so it takes a long time to fsck and it currently holds 115GB 
> of data.
> 
> So why won't this RAID restart on boot when the other does?
> 
> Thanks for any help!
> 
> Hal
> 
> 
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> 

-- 
Hank Marquardt <hank@yerpso.net>
http://web.yerpso.net
GPG Id: 2BB5E60C
Fingerprint: D807 61BC FD18 370A AC1D  3EDF 2BF9 8A2D 2BB5 E60C



Reply to: