[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

reinstalled windows xp serious sarge unidentified problem ended in Kernel-panic please help....

I encountered a kernel panic on sarge after M$ XP reinstalled,which i tried to recover by all ways which i know.i already recovered grub.the partition number descended by one number after windows reinstalled;Now i have  sata 80GB disk with '/' at sda8 and'/boot' at sda9.i already recovered grub.but the kernel panic which no other distros gave...please enlighten/help me getting this solved...
here is the details:
system startup handwritten :(

scsi0 :ata_piix
ATA: abnormal status 0x7F on port 0xE007
ata2 : disabling port
scsi1 :ata_piix
Vendor:ATA Model:ST380013AS Rev:3.18
Type: Direct-Access ANSI scsi revision:05
ide:Assuming 33Mhz system bus speed for PIO modes;override with idebus=xx
scsi device sda:156301488 512-byte hdwr sectors (80026 MB)
scsi device sda:drive cace:write back
scsi device sda:156301488 512-byte hdwr sectors (80026 MB)
scsi device sda:drive cace:write back
sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 sda11 >
Attached scsi disk sda at scsi0,channel0,id0,lan0
VFS:Can't find ext3 filesystem on dev sda7.
mount:wrong fs type,bad option,bad superblock on /dev/sda10,
missing code page or other error
In some cases useful info is found in syslog -try
dmesg |tail or so.
Switching root ...
/usr/lib/yaird/exec/run_init ; current directory on the same filesystem as root:Success
kernel panic -not syncing:Attempted to kill
as you can see the kernel is searching for ext3 on /dev/sda10 while sda8 now contains sarge and sda7 is swap...
heres the edited fstab...
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda8      /               ext3    defaults,errors=remount-ro 0       1
/dev/sda9      /boot           ext3    defaults        0       2
/dev/sda7       none            swap    sw              0       0
/dev/hdb        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hda        /media/cdrom1   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
root@sputnik:~# fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         625     5020281    7  HPFS/NTFS
/dev/sda2             626        5357    38009790    f  W95 Ext'd (LBA)
/dev/sda5             626        1221     4787338+   b  W95 FAT32
/dev/sda6            1222        1532     2498076    b  W95 FAT32
/dev/sda7            1533        1666     1076323+  82  Linux swap / Solaris
/dev/sda8   *        1667        2991    10643031   83  Linux
/dev/sda9            2992        3003       96358+  83  Linux
/dev/sda10           3004        4567    12562798+   b  W95 FAT32
/dev/sda11           4568        5357     6345643+  83  Linux
i already posted this in linuxquestions.org and other sites with no reply for the past 4 weeks...debian geeks please help me........

Reply to: