[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: samba file deletes slow SOLVED



I actually solved the problem. As i said, I was running 2 uml's on that
system and used bridging to allow the uml's to have network access. On
one of those uml's i run my dns server and so it needs to be up and
running before the other services boot as they need dns to find stuff
around the lan.
I moved the uml bridge script and the 2 start scripts of the uml's to
the front of the startup sequence. The tap devices that need to be
created for the  uml's are started as the user uml, but at the system
boots, this user isn't know yet as it's only available in ldap and ldap
is started after the uml's.
This meant the uml's booted allright but the bridge script gave an error
and didn't make the tap devices so the dns server was unreachable.
Some services like apache failed because of the not running dns server
others didn't or at least not that obvious.
I then created an uml user and uml group in the files /etc/passwd and
/etc/group via the adduser and addgroup tools so the uml user would be
known even when ldap wasn't started yet.
After rebooting, the bridge script started ok and the problem went away.
Pretty weird if you ask me but it works again.

Regards,
Benedict

-- 
Benedict Verheyen                   Debian User
http://www.heimdallit.be            Public Key 0x712CBB8D



Reply to: