[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PCMCIA Wireless Card startup problems under Debian Sid


This is my first posting to the list so apologies in advance if this has already been asked.

I have been a linux user for 4 years now and have tried all the major distros at some point (Mandrake, Red Hat, Fedora, SuSe, etc). I recently decided I was ready to move onto the supposedly more difficult to install Debian. My first install of Sarge went painlessly and worked beautifully straight away. Everything was detected pretty well, and apart from a few tweaks to my XFree86-config file to get the synaptics touchpad working to my liking I had nothing difficult or arcane to do.

I was happy like this for a while and was loving everything about Debian. Then I began to get adventurous. I wanted to see what I was missing with Debian Sid. I liked the idea of more up to date software and a more current development environment to play with.

Using a Sarge net-install disc I set about the install process again and using the expert options I selected the unstable sources. After flying through all of the initial setup tasksel choked on the desktop environment task. It would complain incessantly about unmet dependencies with the Openoffice.org-kde package. Not a problem, I simply did "apt-get install gnome openoffice.org kde" and off it went. Everything installed perfectly and after installing a few other bits and bobs, (xserver-xorg etc) I was into a perfect desktop environment. Everything was lovely and I was very happy. The laptop's monitor worked beautifully, Syanptics touchpad was working perfectly, and my Wireless connection was up and running.

The problem started after a reboot. When the laptop rebooted the Wireless card powered on but wouldn't connect. Once logged in I had to manually do "ifup eth1" as root to get connected. Not a huge deal, but annoying enough if you have to do it after every reboot!

I searched through google looking for an answer but couldn't find anything specific enough. My suspicion is that it has something to do with udev, since the card worked flawlessly under Sarge. I have tried removing the pcmcia-cs package after seeing something on google about this package being obsolete in conjunction with udev, but that just killed the card all together. Can anyone advise me what I have done wrong? I am at a loss as to how the new udev replaces hotplug, or how it interacts with the hardware. Is there a straight forward fix available?

My hardware is as follows:

HP Pavilion ZT1125 Laptop + Enterasys Roamabout (Re-badged Orinoco Gold) PCMCIA Wireless Card.

Any help would be greatly appreciated and apologies for the long winded email.

James Caldow

Reply to: