[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: how to start php

Clive Menzies wrote:
> On (02/10/05 14:56), Eric P wrote:
>>Clive Menzies wrote:
>>>On (02/10/05 01:48), Eric P wrote:
>>>>Hi all,
>>>>Php4 was up and running.  Then I tried out dotdeb's php5.  Decided to
>>>>switch back to php4, but now php4 doesn't start when I restart Apache or
>>>>even reboot.  I reinstalled php5, but no luck with that either now.
>>>>Currently, I have the following installed on testing:
>>>You seem to be missing php5 itself; php doesn't run as a daemon AFAIK,
>>>it processes scripts on demand.
>>Just installed the php5 package.
>>Restarted Apache... no php.  Then rebooted... no php.
>>Here's what the footer shows on a page on my local server.
>>Apache/2.0.54 (Debian GNU/Linux) mod_python/3.1.3 Python/2.3.5
>>mod_perl/1.999.21 Perl/v5.8.7 Server at localhost Port 80
> I presume if you try to access the server from a webrowser, you see the
> Apache intro page? 
Yep.  Apache is up and running.  The footer above is from a directory
listing on the server.
> If you do, try installing phpmyadmin and seeing if it will run.
It's installed, but doesn't run.  I've just been testing with a simple
script:  <?php phpinfo(); ?>

> You could also try:
> $ dpkg-reconfigure <package> 
> where <package> = php5 php5-mysql apache2 etc.
Ahh... yes, I forgot about that.

However, this returns a blank link (no config dialogs are presented).
# dpkg-reconfigure php5 apache2

I went ahead and removed php5-mysql for the time being.

Jon, what kind of script are you referring to?  The first time I
installed php5 (from dotdeb), it automatically prompted me to config
php5, and everything worked w/o any manual intervention.  Switching back
to php4 (which I did on a whim because php's mysql_pconnect() didn't
work anymore) is where the problems started.

Anyway, thanks again,
Eric P

Reply to: