[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

XFree86 does not "find device" for a i915 chipset using the i810 driver

Dear Debian people,

I can not get my XFree86 to work with the i810 driver, and tried for
hours with various Google-based tips, so now I ask you.

Problem: Only the VESA driver loads, and I can only work at 1024x768,
while my LCD screen is a 1280x1024.


X does not start when I try to use the i810 driver. At the end of the
error log it says "Device not found".

I have a relatively standard computer - a Fujitsu-Siemens P4-PC, with an
integrated i82915 graphics card.
The card is detected by lspci:

0000:00:02.0 VGA compatible controller: Intel Corporation
82915G/GV/910GL Express Chipset Family Graphics Controller (rev 04)

It is correctly detected during startup:
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected an Intel 915G Chipset.
agpgart: Detected 7932K stolen memory.
agpgart: AGP aperture is 256M @ 0xe0000000

 and lsmod gives:
intel_agp              24092  1
agpgart                35560  1 intel_agp

In the XF86Config-4 file I try to use "i810" driver, but it does not
work. Only the "Vesa" driver works.
Section "Device"
	Identifier	"Generic Video Card"
	Driver		"vesa"

Section "Device"
	Identifier	"Intel Integrated Video"
	Driver		"i810"
I have tried to also specify the BusID, but it made no difference.

uname -a says:
Linux gilbert 2.6.12-1-686 #1 Tue Sep 6 15:10:40 UTC 2005 i686 GNU/Linux

I use the "unstable" branch, and I have had this problem ever since I
first installed the system in March 2005.

Does anyone have any tips on how to proceed?
What else should I try?

Best regards,
		Goran Christiansson

Reply to: