[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bootlog [was: control of modules?]

On 9/30/05, Edward J. Shornock <debian-ml@crazeecanuck.homelinux.net> wrote:
> Matt Price wrote:
> > that helps some -- got rid of most of the messages except one about
> > shpchp, which is not listed in my /etc/modules, so don't know the
> > origin.  Unfortunately cna't post my bootlog b/c bootlogd doesn't seem
> > to wantto run!  I have the following /et/default/bootlogd:
> > # Run bootlogd at startup ?
> >
> > ... but still no /var/log/boot.  Not sure what that's about; I noticed
> > another thread from someone with a similar difficulty, no solution
> > posted, not sure what's going on.
> What version of sysvinit do you have installed?  There's a bug that's
> been in sysvinit since 2.86.dsl1-1 which affects bootlogd.  See the bug
> report at
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=327865 for a patch that
> fixes the problem for me and a few others.

thanks for this.  Using the first-posted version of the patch (the one
from greek0.net is unreachable right now, I guess), I tried the

apt-get source sysvinit
apt-get build-dep  sysvinit

cp 50_bootlogd_exitcode.dpatch debian/patches
debuild -uc -us

patches seem to apply properly, but the package won't build, I get this error:

(cd src; make DISTRO=Debian WITH_SELINUX="yes")
make[1]: Entering directory `/home/matt/sysvinit-2.86.ds1/src'
gcc -ansi -W -Wall -O2 -fomit-frame-pointer -D_GNU_SOURCE   -c -o
mountpoint.o mountpoint.c
make[1]: gcc: Command not found
make[1]: *** [mountpoint.o] Error 127
make[1]: Leaving directory `/home/matt/sysvinit-2.86.ds1/src'
make: *** [build] Error 2
debuild: fatal error at line 765:
dpkg-buildpackage failed!

this is on a recently-upgraded sid.  Apparently there's no gcc symlink
on my box!  lots of gcc's installed, e.g. gcc-2.95, gcc-3.0, gcc-3.2,
gcc-3.3, gcc-4.0, but not /usr/bin/gcc.  DO I need to sett his
somehow?  with update-alternatives perhaps?


Reply to: