[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: WiFi on Toshiba Sattelite A70 Atheros 5004X

NdisWrapper emulates a windows-driver. Maybe you want to consider using madwifi which would be a native dirver. If you are interested have a look at the following sites:


Hope, this helps.


David R. Litwin wrote:

I have recently acquired a Toshiba A70. It has a WiFi card: an Atheros 5004X. This is built in to the machine, so I have no need to purchase another one.

Now, I do need a driver for this. I have looked, and it seems to me that the NdisWrapper would be the Driver for me. It gives two options: The DebianNoCompiles and the InstallDebian. But, I am running a 2.6.12 kernel (Sid, X.org <http://X.org>, KDE 3.4.2) and the apt-gettable modules (for DebianNoCompiles) are for the 2.6.8 kernel. So, that clearly will not work. Downloading the file from Sourceforge, I tried to follow the instructions:

cd /usr/src
tar jxvf ndiswrapper-source.tar.bz2
cd modules/ndiswrapper
fakeroot debian/rules binary-modules

I changed the file to reflect the file I downloaded and attempted to cd in to modules/ndiswrapper (after cding in to the created folder). Modules does not exist. Well, I tried to debian/rules binary-modules. This did not work with error:

make: dh_testdir: Command not found
make: *** [common-prolog] Error 127

Clearly, this is not working. Perhaps I shouldn't even be doing this. I would also like to not have to comile my own kernel, unless I absolutely need to.

I should love it if some one could tell me what to do; or give me a nice HOWTO. I shall, of course, continue to fiddle about, attempting to make things better.

As always, I thank the reader kindly in advance.

—A watched bread-crumb never boils.
—My hover-craft is full of eels.
—[...]and that's the he and the she of it.

Reply to: