[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X won't start having upgraded from xsever to xorg

Tong Sun wrote:

>This is a real emergency. My X won't start now, having
>upgraded from xsever to xorg. 
>Is there any way I can have my X back? 
>I saw in thread 
>Routine upgrade of packages tracking etch has hosed
>that there is way to restore using xserver instead of
>xorg. I tried to follow it, but wasn't successful. 
>I removed all xorg and xserver packages and reinstall
>xserver from scratch, but still I was forced to
>install xorg. 
>I installed the xorg, try its hardware auto-detection,
>again, but still my X won't start. The sypmtom is,
>still, the screen gets into graphic mode, with garbage
>on it, and the whole system just freeze. I tried
>Ctrl-Alt-\, Ctrl-Alt-F?, Ctrl-Alt-Del, nothing worked.
>Please help. It's a real emergency, and I'm desperate.
>Is there any way, any?
Are you running Sarge (nope; no X.org yet), Testing, or Sid? (Uninstall
all of X, change your /etc/apt/sources.list file to the older version,
and then install X, would be one possible tactic.)

Is the problem really with X, or with a certain
einvironment/manager/client? (Have you tried other means of starting X,
such as kdm, gdm, startx, with different window managers/environments?)


Reply to: