[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ext3 and rsync problem

I have a SATA hard disk in my machine, and recently installed a 200gb Seagate
IDE hard drive in it to use as backup.  I want to use rsync to backup my home
directory to this machine.  I used mkfs.ext3 to format the drive as ext3, and
mounted the drive (mount -text3 /dev/hdc /bkup).  I then made a directory
/bkup/ric with the appropriate permissions, and then  I tried to begin using
rsync to copy my home directory to the drive:
    rsync -av /home/ric /bkup
This failed, and I got several error messages of the form:
  rsync: recv_generator: mkdir "/bkup/ric/samba" failed: Read-only file system (30)
  rsync: stat "/bkup/ric/samba" failed: No such file or directory (2)
  rsync error: some files could not be transferred (code 23) at main.c(789)
Upon restart, the drive would not mount.  fsck gave me:
  /dev/hdc contains a file system with errors, check forced.
  Pass 1: Checking inodes, blocks, and sizes
Eventually it gave hundreds of errors that needed to be fixed.  So I
reformatted the drive with mkfs.ext3 and tried again, with the same results.

I then tried using "cp -r --preserve" to transfer the larger directories over,
which worked; upon restart the drive was mounted, and fsck reported no
problems.  So I tried to rsync the rest of my home directory to it, and got the
same errors.  I tried this whole procedure a couple of times, with the same
results.  I seem to be able to copy files over using cp, but not using rsync.
I did notice that mkfs.ext3 made a directory "lost+found" which I have never
noticed before. 

I was wondering if anyone had any ideas of what I'm doing wrong.  I tried
this using both sarge and sid (I have a dual boot machine).  Thanks,


Reply to: