[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


If ALSA sound does not interest you, neither will this post.  You can
skip it.

I wrote:
> [...]
> <thb> Sound problem.  On my system, /dev/dsp, /dev/midi and other sound
>   devices seem to accept sound data as normal, but the speaker produces
>   no sound.  My mixer is not zeroed.  I've ALSA and NAS installed, plus
>   Esound and Jack because other packages depend on them.  If you have
>   experience debugging Debian sound: where should I start looking for
>   the solution, please?
> <asg> thb: does 'cat /dev/urandom > /dev/dsp' produce a horrible noise?
>   silence? or an error?
> <thb> asg: thanks; stand by
> <thb> asg: I ran the command you suggested as root.  Silence, no error,
>   no exit until I hit ^C.
> [...]
> <Blissex> thb: you may have one of those cards without mute/unmute then.
> <thb> Blissex: my sound chip is very common: AD1981, included on
>   millions of recent Intel boards.  There is nothing unusual about it.
> <Blissex> thb: are you using the 'snd-intel8x0' driver though?
> <thb> Blissex: yes.  Hard-compiled into the kernel; not a module.
> <Blissex> thb: BTW ALSA should not be really compiled in the kernel,
>   there may be problems if it is done like that.
> <thb> Blissex: wow!  That, I did not know.  Very good.
> <Blissex> thb: also have a look here: http://alsa.opensrc.org/intel8x0
>   and the 8x0 subsection of http://tinyurl.com/4ogk2

For the record, Blissex' suggestion seems to have solved my problem.
ALSA had failed when recompiled monolithically into my 2.6.8 kernel; but
now that I configure ALSA as a set of modules and recompile the kernel
again, it seems to work fine.  If you encounter a similar problem---if
you have recompiled your 2.6 kernel monolithically and the snd_intel8x0
ALSA driver mysteriously produces no sound---try restoring
module-loading support, then recompile your kernel again with the ALSA
units as loadable modules.  Your kernel doesn't need any fancy automatic
module handling if you don't want it; basic CONFIG_MODULES and
CONFIG_MODULE_UNLOAD suffice.  See the Debian binary
package 'kernel-package' and the modprobe(8) manpage for further info.

How applicable the advice is to systems having non-intel8x0 sound chips
or running non-2.6 kernels, I admit that I do not know; Debian sound is
not my area of expertise and I don't know much about it.  This post is
to report for the list archive what happened to work for me.  For the
benefit of confused Debian beginners who may stumble upon this post,
however, I should observe that unless you have deliberately recompiled
your kernel (this does not happen by accident; if you had done it, you
would know), the advice probably does not pertain to you.

(It may not matter, but to complete the technical report: my specific
motherboard is the Intel D845GEBV2L.  This motherboard provides sound
through an onboard Analog Devices AD1981 chip, which is one of the
several chips the snd_intel8x0 ALSA driver drives.  The reference OS is
Debian 3.1r0a sarge stable.)

I am not subscribed to debian-user, so please e-mail me directly if you
want to reach me over this.

Thaddeus H. Black
508 Nellie's Cave Road
Blacksburg, Virginia 24060, USA
+1 540 961 0920, t@b-tk.org, thb@debian.org

Attachment: signature.asc
Description: Digital signature

Reply to: