[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Some people on the #debian IRC channel gave me some useful advice
regarding Debian, sound and ALSA yesterday.  It seems unlikely that the
advice is useful just to me.  If it is good to post the advice where
others can search it out later, then the relevant log extract follows.

Keywords: Debian, sound, ALSA, OSS, NAS, mixer, amixer, scontrols, dsp,
kernel, module, Intel, AD1981.

#debian    thb       H   (Thaddeus H. Black)
#debian    Blissex   H   (http://WWW.sabi.co.UK/)
#debian    asg       H   (Adam Garside)
#debian    Niki      H   [/whois not captured]
#debian    [nick1]   H   [actual nick unprintable]
<thb> Sound problem.  On my system, /dev/dsp, /dev/midi and other sound
  devices seem to accept sound data as normal, but the speaker produces
  no sound.  My mixer is not zeroed.  I've ALSA and NAS installed, plus
  Esound and Jack because other packages depend on them.  If you have
  experience debugging Debian sound: where should I start looking for
  the solution, please?
<asg> thb: does 'cat /dev/urandom > /dev/dsp' produce a horrible noise?
  silence? or an error?
<thb> asg: thanks; stand by
<thb> asg: I ran the command you suggested as root.  Silence, no error,
  no exit until I hit ^C.
<asg> thb: okay, then your mixer may be mutted irrespective of the
<asg> thb: or your speakers are not plugged in or wired properly.
<Blissex> thb: read carefully the troubleshooting, OSS comaptibility and
  app config sections of http://tinyurl.com/4ogk2
<thb> asg: Okay.  I'll go chew on that for a while.
<thb> Blissex: thank you.  I will do it.
<[nick1]> Blissex, you wrote this conf?
<Blissex> [nick1]: yes, I did. More or less precisely for people like
  your and <thb>.
<Niki> thb: Please run: amixer set 'Master' 'unmute' '100' and  amixer
  set 'PCM' 'unmute' '100', the try again.
<thb> Niki: understood; stand by.
<thb> Niki: error message: "amixer: Unknown playback setup 'unmute'.."
<Blissex> thb: swap around the "100" and "unmute".
<thb> Blissex, Niki, asg: same error message after swapping.  All right.
  Something is evidently set up wrong on my system, but you have given
  me some good ideas where to start looking for the solution.  With
  these new clues, I should go away for a while now and work on the
  problem some more.  Thank you.  I may return with further questions
<asg> thb: good luck on getting things working
<Niki> thb: Goog luck!
<Blissex> thb: try this more precisely:
<Blissex> thb: amixer sset Master 80% unmute
<Blissex> thb: some cards however do not need to have controls unmuted,
  so if that the case, remove the "unmute".
<thb> Blissex: Hrm.  Same error msg: "amixer: Unknown playback setup
<Blissex> thb: to see what you can set or not, 'amixer' or 'amixer
  scontrols' or 'amixer scontents'
<Blissex> thb: [nick1]: BTW, usually you should ask sound questions in
<thb> Blissex: didn't know about #ALSA; now I know.  To answer the
  question about "amixer scontrols", it replies normally: it lists five
  simple mixer controls: Master, Synth, Line, CD, Mic.
<Blissex> thb: you may have one of those cards without mute/unmute then.
<thb> Blissex: my sound chip is very common: AD1981, included on
  millions of recent Intel boards.  There is nothing unusual about it.
<Blissex> thb: are you using the 'snd-intel8x0' driver though?
<thb> Blissex: yes.  Hard-compiled into the kernel; not a module.
<Blissex> thb: BTW ALSA should not be really compiled in the kernel,
  there may be problems if it is done like that.
<thb> Blissex: wow!  That, I did not know.  Very good.
<Blissex> thb: also have a look here: http://alsa.opensrc.org/intel8x0
  and the 8x0 subsection of http://tinyurl.com/4ogk2

I am not subscribed to debian-user, so please e-mail me directly if you
want to reach me over this.

Attachment: signature.asc
Description: Digital signature

Reply to: