[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PS/2 mouse not working with USB legacy option enabled in Kernel 2.6


I have been using Debian 3.1 (Sarge) with kernel 2.6.8-2-386 on my Pentium M system. A couple of days ago I noticed that my PS/2 mouse won't work when I enable the 'Legacy USB' option in my BIOS setting. If I disable the 'Legacy USB' option, my PS/2 mouse works fine along with USB mouse. My USB mouse works fine in both the situation i.e. when the 'Legacy USB' is enable/disable I have tried the workarounds like:

psmouse.proto=imps and i8042.nomux as kernel boot parameters but it didn;t help.

I did a lot of researching over the Internet and then I found that it is because in Kernel 2.6 they have moved the drivers into the kernel space from the user space. Unfortunately I was not able to find a solution how to get the PS/2 mouse working with USB Legacy option enabled in the BIOS.

Also, I have tried the following link but I was not successful.

Also the following links reports that it is a bug but apparently no clear solution has been given.

Any help will be greatly appreciated.

I will be glad to post any diagnostic output like:
cat /proc/bus/input/devices
lspci -xvvv

Kushal Koolwal

Reply to: