[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PPP Carrier Detect problem.

On Mon, Aug 22, 2005 at 11:32:52AM +0200, Louis Swart wrote:
> Hi,
> I have a Debian GNU/Linux 3.1 Intel x86 installation that has pppd
> version 2.4.3.
> I have a GPRS modem connected to /dev/ttyS0.
> I can connect and get a ppp0 interface.
> When I unplug the GPRS modem from the serial port I can
> see the modem signals change state including CD (Carrier Detect):
> >From : 0: uart:16550A port:000003F8 irq:4 tx:2276 rx:2864 RTS|CTS|DTR|DSR|CD
> To : 0: uart:16550A port:000003F8 irq:4 tx:2329 rx:2911 CTS|DSR
> But pppd does not close the connection and the ppp0 interface remains
> available.
> If I do the same test on Fedora Core 3 that has pppd version 2.4.2 all
> works 100%.
> Can anyone confirm this and possibly give a solution?
> I have tried different combinations of "crtscts", "cdtrcts" and
> "modem" with no good result.
Have you tried lcp-echo-interval and lcp-echo-failure?

Knowledge, sir, should be free to all!
		-- Harry Mudd, "I, Mudd", stardate 4513.3

Reply to: