Re: upgrade from python2.3 to python2.4
On Thursday 04 August 2005 22:42, firstname.lastname@example.org
> > > I downloaded a game sudoku recently but I'm having troubles installing
> > > it. It requires Python 2.4 or higher and when I downloaded it first
> > > Python 2.3 was on my system. So I searched in aptitude if I can
> > > upgrade it and I found Python 2.4 - so I installed it. Tried to
> > > install the sudoku application but a message
> > >
> > > Error: Python-2.4 or newer is required. Current version:
> > > 2.3.5 (#2, Jun 19 2005, 13:28:00)
> > > [GCC 3.3.6 (Debian 1:3.3.6-6)]
> > Try to run the program with "python2.4 theprogram" instead of just
> > "theprogram".
> > cheers,
> > Christian
> Thank you very much, so simple, yet I would never have thougt of that
> since I've been looking at the install instructions where they say
> nothing about that option...
> Anyway, when I thought the problem has been solved, it occurs
> something else has got in my way...
> This game requires 'PyGTK-2.3.93 or newer' also so I tried to install
> it... I downloaded the pygtk-2.4.0 and run
> # ./configure --prefix=/usr/lib/python2.4
> as in instructions but I always get this line at the end:
> # checking whether /usr/lib/python2.4 version >= 2.3... configure:
> error: too old
> Then I read in the pygtk readme file the next:
> If your Python interpreter isn't in the path, or is not called
> "python", you can set the PYTHON environment variable to the full path
> of the interpreter:
> $ PYTHON=/prefix/bin/python
> $ export PYTHON
> And I entered:
> # PYTHON=/usr/bin/python2.4
> # export PYTHON
> But no change.
> I just spent so much time trying to search for a solution on the net
> but can't afford to loose any more time.
> I mean, it is a great game and in my opinion worth all the trouble but
> at the moment this just isn't a good use of my time. Maybe some of you
> good folks comes up with an idea in the mean time or tells me what I
> have been doing wrong.
I went through all of this as well. There is apparently no Debian package for
one of the routines it uses so even 2.4 failed.
So ... I changed the code to "require" 2.3 and finally got it toe compile. Get
an error when I try to run it.
I you want sudoku, there is a quick and dirty ruby program around. SInce it
actually runs in a thinkly disguized xterm, firewall messages and such cover
the board and their is no refresh. Better, get the sgt-puzzles package. Among
its game clones of minesweeper, mastermind and such, there is "solo" which
is ... sudoku and reasonably done.