[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

floppy auto type

Hi !

I used to have in my fstab:

/dev/fd0	/floppy		auto	user,noauto		0	0

And it used to work well.  I tried mounting /floppy and it failed:

% mount /floppy
mount: I could not determine the filesystem type, and none was specified

As root I tried:

# mount -t auto -v /dev/fd0 /floppy
mount: you didn't specify a filesystem type for /dev/fd0
       I will try all types mentioned in /etc/filesystems or /proc/filesystems
mount: you must specify the filesystem type

So, it didn't work either.  As this is a vfat floppy disk I tried as root:

# mount -t vfat /dev/fd0 /floppy

And it worked...  According to "man mount":

If  no  -t  option  is  given, or if the auto type is specified, mount
will try to guess the desired type.  If mount was compiled with the
blkid library, the guessing is  done  by  this library. Otherwise,
mount guesses itself by probing the superblock; if that does not turn
up anything that looks familiar, mount will try to read the file
/etc/filesystems, or, if  that does  not exist, /proc/filesystems. 
All of the filesystem types listed there will be tried, except for
those that are labeled "nodev" (e.g., devpts, proc and nfs).  If
/etc/filesystems ends in a line with a single * only, mount will read
/proc/filesystems afterwards.

The auto type may be useful for user-mounted floppies.  Creating a
file /etc/filesystems can be useful to change the probe order (e.g.,
to try vfat before msdos or ext3 before ext2)  or if  you use a kernel
module autoloader.  Warning: the probing uses a heuristic (the
presence of appropriate `magic'), and could recognize the wrong
filesystem type, possibly with catastrophic consequences. If your data
is valuable, don't ask mount to guess.

I looked into /proc/filesystems:

nodev	sysfs
nodev	rootfs
nodev	bdev
nodev	proc
nodev	sockfs
nodev	binfmt_misc
nodev	usbfs
nodev	pipefs
nodev	futexfs
nodev	tmpfs
nodev	eventpollfs
nodev	devpts
nodev	ramfs
nodev	nfs
nodev	nfs4
nodev	nfsd
nodev	smbfs
nodev	autofs
nodev	rpc_pipefs

So vfat is part of those filesystems that should be tried
automatically.  This used to work before.  Is there any mistake with
mount?  I'm using:

% mount -V
mount: mount-2.12p

Which corresponds to debian unstable...  Has anyone noticed this?  Any


Javier-Elias Vasquez-Vivas

Reply to: