[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CD problem: hardware or software?

On Fri, Jul 29, 2005 at 08:16:06AM -0500, Daniel Ramaley wrote:
> I'm running testing on a PowerPC (a Mac Mini to be precise). I have an 
> external CD drive that i am using to rip my CD collection (i'm using an 
> external to avoid wear and tear on the more expensive internal drive). 
> The problem is that after bootup i can rip CDs for a little while 
> (where "a little while" ranges from 1/2 of a disc to 10 discs, usually 
> towards the lower end of the range), but then errors start showing up 
> in dmesg and on the console. The only way to resume ripping is to 
> reboot the computer; detaching the CD drive, power cycling the CD, and 
> reconnecting it to the computer doesn't fix the problem. If i reboot 
> the computer and power cycle the CD drive, the problem is fixed and i 
> can resume ripping right where i left off (which implies to me that the 
> problem isn't with the discs i've been ripping).
> The external drive has both ieee1394 and USB 2.0 interfaces. I've tried 
> connecting it to either one, and the same problem occurs. Any ideas 
> whether this is a hardware or a software issue?
> Here's what shows up in dmesg when ripping CDs (there are many more 
> messages, all identical except sometimes the 30576 number changes). 
> These messages show up right away, before any actual problem is 
> evident:
> sg_write: data in/out 30576/30576 bytes for SCSI command 0xbe--guessing 
> data in;
>    program cdparanoia not setting count and/or reply_len properly
> printk: 198 messages suppressed.
> Once the problem occurs, this is what gets printed on the terminal. 
> Again, there are many copies of this message; this is just a sample:
> scsi_read error: sector=313943 length=1 retry=3
>                  Sense key: 0 ASC: 0 ASCQ: 0
>                  Transport error: Error reading command from device
>                  System error: Success
have you tried ripping at slower speeds? 1x, 2x. 3x....
if the problem does not occur at 1x,2x,3x, then you may have to burn at
slower speed. Some folks say that under linux (from random comment I
read) you need to burn slower than the drive is rated.
just a thought.
counter.li.org #238656 -- goto counter.li.org and be counted!
      `$'         $'         
       $          $                      _
 ,d$$$g$  ,d$$$b. $,d$$$b`$' g$$$$$b $,d$$b
,$P'  `$ ,$P' `Y$ $$'  `$ $  "'   `$ $$' `$
$$     $ $$ggggg$ $     $ $ ,$P""  $ $    $
`$g. ,$$ `$$._ _. $ _,g$P $ `$b. ,$$ $    $
 `Y$$P'$. `Y$$$$P $$$P"' ,$. `Y$$P'$ $.  ,$.

Attachment: signature.asc
Description: Digital signature

Reply to: