[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Cross-compiling Firefox

I'm trying to cross-compile Firefox from CVS, for a win32 target.  Have
poked around for help but this is a bit of a last resort.  Might
interest someone.

configure reports:

checking for i586-mingw32msvc-ranlib... (cached) ranlib
checking for i586-mingw32msvc-ar... (cached) ar
checking for i586-mingw32msvc-as... (cached) /usr/bin/as
checking for i586-mingw32msvc-ld... (cached) ld
checking for i586-mingw32msvc-strip... (cached) strip
checking for i586-mingw32msvc-windres... i586-mingw32msvc-windres
checking for w32api version >= 2.4... no
configure: error: w32api version 2.4 or higher required.

The program that fails is:

#include "confdefs.h"
#include <w32api.h>
int main() {
#if (__W32API_MAJOR_VERSION < 2) ||
(__W32API_MAJOR_VERSION == 2 &&                  __W32API_MINOR_VERSION < 4)
                #error "test failed."

; return 0; }

I can see the w32api.h file is present at
/usr/i586-mingw32msvc/include/w32api.h.  How can I tell configure to
look in here, and should it not be doing this already given that it was
passed the option --target=i586-mingw32msvc?


Reply to: