[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't locate Apache2.pm in @INC



On Sunday July 31 2005 16:36, Paul Scott wrote:
> I presumably can follow the instructions below but I am running sid and
> have the latest packages.  I just installed the new libapache2-mod-perl2
> that showed up after I sent my first post and it is still broken.  What
> updated packages are you referring to?  I have no non-Debian code that
> uses mod-perl.

Due to the renaming, some packages that are using mod_perl2 might have some 
problems. Mason is one case where it took some time for a working version to 
get into sid. If you're using any handlers that might cause a problem, 
disable them one by one to find the problem.

> >Here's the description of the problem along with some advice on how to fix
> >your own code:
> >http://perl.apache.org/docs/2.0/rename.html#Effects
>
> I had seen that and will reread it but was wondering if there was a
> Debian package solution.

If you're getting the message when starting Apache, you'll have to 
check /etc/apache2 for some file trying to load the module. If you have a 
link /etc/apache2/mods-enabled/perl.conf, delete it or just remove the line 
"use Apache2;" if you changed it yourself. It was part of the older mod_perl2 
releases which required the module to be loaded to redirect the Apache 
namespace. If there's nothing in in anymore, you can also delete the linked 
file at /etc/apache2/mods-available/perl.conf.

-- 
Got Backup?

Jabber: Shadowdancer at jabber.fsinf.de

Attachment: pgpfCX4ScrQwb.pgp
Description: PGP signature


Reply to: