[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Tryin' to install Debian on an HP Netserver...

Hi folks,

I have an old HP Netserver (nice machine, with a built-in SCSI-RAID and an SMP 
Hardware data:
2 Intel Pentium Pro 200 MMX, 128 MB RAM
two on-board Adaptec AIC 7880U (one free, one for CD-ROM and a 2 GB Boot-HDD) 
one RAID-Controller Mylex Corporation DAC960P (rev 2) (for the RAID-system)
one Future Domain Corp. TMC-18C30 [36C70] (rev 0) (for another 50 GB SCSI-HDD)

It's running fine with Red Hat Linux release 7.3 (Valhalla), but now, I'd like 
to install Debian Sarge on it. Since Linux is already running, and I had 
several problems in the past with this machine when I tried booting from CD, 
I decided to boot from HDD using Grub.
So, I downloaded vmlinuz and initrd.gz, copied them to /boot, and added the 
follwoing lines to my /boot/grub/menu.lst:

title Debian Install
        root (hd0,0)
        kernel /vmlinuz.debian root=/dev/ram0 ramdisk_size=4096
        initrd /initrd.debian.gz

So far, so good - but, when I try to boot the installer, I see the following 
messages on the screen:
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
Linux IP multicast router 0.06 plus PIM-SM
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 3019k freed
VFS: Mounted root (ext2 filesystem) readonly
Freeing unused kernel memory: 96k freed
attempt to access beyond end of device
01:00: rw=0, want=9505, limit=8192
Warning: unable to open an initial console
Kernel panic: Attempted to kill init!

After this, the machine hangs. I tried plain' around with the ramdisk_size, 
but no success...
Any ideas?

Thanks, and have a nice hackin',

This message was sent with Fedora Linux
Free Software for a free world!

Dipl.-Ing. Harald Husemann
58840 Plettenberg
e-Mail:   bofh@dh9dat.de
Projects: rawt.sourceforge.net

Reply to: