[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CD problem: hardware or software?

On 15:59, Fri 29 Jul 05, Clive Menzies wrote:
> On (29/07/05 08:55), Daniel Ramaley wrote:
> > On Friday 29 July 2005 08:26 am, Hendrik Boom wrote:
> > >On Fri, Jul 29, 2005 at 08:16:06AM -0500, Daniel Ramaley wrote:
> > >> I'm running testing on a PowerPC (a Mac Mini to be precise). I have
> > >> an external CD drive that i am using to rip my CD collection (i'm
> > >> using an external to avoid wear and tear on the more expensive
> > >> internal drive). The problem is that after bootup i can rip CDs for
> > >> a little while (where "a little while" ranges from 1/2 of a disc to
> > >> 10 discs, usually towards the lower end of the range), but then
> > >> errors start showing up in dmesg and on the console. The only way to
> > >> resume ripping is to reboot the computer; detaching the CD drive,
> > >> power cycling the CD, and reconnecting it to the computer doesn't
> > >> fix the problem. If i reboot the computer and power cycle the CD
> > >> drive, the problem is fixed and i can resume ripping right where i
> > >> left off (which implies to me that the problem isn't with the discs
> > >> i've been ripping).
> > >
> > >Could something be overheating?  You could perhaps try putting the
> > >external drive in the refrigerator for a few minutes, but not long
> > > enough that condensation can become a problem.  Then take it out and
> > > see if it works any longer.  It is an external disk, after all.
> > >
> > >Of course it could be another part overheating, such as the USB
> > > interface inside the computer, which is harder to refrigerate.
> > >
> > >I had problems like this with a video card a while ago.  It turned out
> > >that one of the cooling fans was clogged with dust and not turning.
> > 
> > Thanks for the quick response. I'll look into cooling issues with the 
> > drive, though i suspect that isn't the problem. The external enclosure 
> > that the drive is in is very new. The cooling fan runs great and isn't 
> > clogged with dust yet. I can try running it with the lid off to see if 
> > that makes a difference. The drive itself is a few years old; it is a 
> > 36x that i pulled from a machine at work that we were sending to 
> > recycling.
> > 
> > I was actually having the same problem on a different machine running 
> > the same software, using the same external drive. The other machine was 
> > a G3 iMac, which shouldn't have heating issues with the USB or Firewire 
> > interfaces since there is more room for air circulation. So i suspect 
> > that the problem is either with the external drive or with the 
> > software. 
> It may be unrelated but I tried 'grip' on an AMD64 laptop but found
> after 4 or 5 tracks, the machine vibrated badly and then shut itself
> down.  It had become really hot and took a while to recover but seems
> fine now.
> Needless to say I uninstalled grip and decided to only rip on a 'cool'
> machine.  
> As Hendrik says, your problem sounds heat related.
> Regards
> Clive
> -- 
> www.clivemenzies.co.uk ...
> ...strategies for business

Does the drive work under Mac OS X, or on another non mac
computer?  This would tell you if its a hardware problem, or
if its a software problem. I would not consider running it
under debian on another mac as a proper hardware test, as it
could be using the same kernel, and modules as your problem

If I remember correctly a few months ago a lot of people
where having various problems with USB and encoding mp3, and
oggs due to a change in the kernel headers. I had that
problem on an older kernel, and had to upgrade the kernel to
fix the problem's. 

What happens if you encode one or two tracks, does it do it
fine. Have you tried to slow the encode, or ripping down by
cmd line to maybe test for this situation.

As far as wearing out the onboard drive, I would not worry
about that, if that happened I am sure your not the only one
who would complain about that to Apple.  I have a cd burner
that is used all the time, and is going on five years.

Have you tried poking around the ppc newsgroups, I know this
might be a debian problem, but someone might of heard of it
on those other groups. This might be something of a bug
report as well, might want to check them to make sure its
not a known problem, maybe someone has a work around ready.


Reply to: