[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Why no more ptys on a Woody System?

Bill Marcum writes:
>What kernel do you have?


>  Is devpts mounted?

THAT'S IT!! No, and now I must figure out why it stopped being
mounted.  I have temporarily stolen the mtab line that shows the mount
from another system and stuck it in fstab, then did mount -a.  The
ptys immediately came to life.  Thank you!

>  In my system (Ubuntu Hoary,
>kernel 2.6.10-5-386), the /etc/init.d/mountvirtfs script mounts devpts.

	That's where things get really weird.  This system did not
have mountvirtfs on it and it worked fine since I put the 2.6.5 kernel
on it in May of 2004.

	I originally built this system in 2001 and had a 2.4.19 kernel
until 2004.

	After installing the 2.6.5 kernel, I never had any trouble
with /dev/pts which was originally last created in June of 2001 so I
am still not sure what I did last Friday.

	I think it is time to backup /usr/local and /home and whack
everything else and reinstall from the latest Debian netinstall CD.
There are a few cobwebs so to speak on the system and I only spent
this much time trouble-shooting to learn something more about how the
boot process works.  The mountvirtfs script appears to be called from
/etc/init.d/checkroot.sh on newer systems.  checkroot.sh on this
system is from April of 2002 and never calls mountvirtfs.

	The only mystery left is why did it work for so long.  There
was something , somewhere besides fstab mounting /dev/pts.

	Thanks tremendously for your help.  It is working normally
until I get the time to give it a rebuild.

Martin McCormick WB5AGZ  Stillwater, OK 
OSU Information Technology Division Network Operations Group

Reply to: