[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Migration to new HD: "unable to open an initial console"

On Wed, 20 Jul 2005 23:50:07 +0200, Marty <martyb@ix.netcom.com>

> Matthijs wrote:
> > I've followed the Debian harddisk-upgrade HowTo, changed fstab
> > according to the above, installed grub on the new harddisk according
> > to a posting here by Mitchell Laks (thanks for that!).
> > 
> > Then I switched the machine off, removed the old harddisk, switched
> > the new harddisk from slave to master and turned the machine on.
> > 
> > Grub executed OK, there's a lot of info scrolling over the screen. At
> > some point there's a message, something like 'mounting /dev/hda1
> > read-only' (don't know exactly since it isn't logged anywhere)
> > 
> > The next message is where it ends: 'unable to open an initial
> > console'.
> The problem seems to be that some console device is required before
> any udev devices are created.
> I've solved this by copying all the devices from a live filesystem
> onto /dev of the cloned drive, but you probably only need xconsole
> or something similar.

I thought about this after posting my original message and checked.
<now checking again...>
Ouch! No /dev/console!

OK, I thought I *did* copy everything from the original filesystem:
> cp -ax / /new-disk
... and even checked when I ran into trouble whether /dev/console
> /ls -l /dev/console
... but I should have checked with
> ls -l /new-disk/dev/console

The directory /dev (and also /sys) are completely empty. Stupid me!

I just copied everything in /dev and /sys again, booting the new
filesystem right now...
YES! Much better now!

Thanks for the help!

No need to 'cc' me, I read the list.

Reply to: