[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to add scroll-wheel mouse to xfree86

En/La Vegard|drageV ha escrit, a 20/07/05 20:47:
> Hi list, 
> from a previous thread I got hints on how to add a Logitech Mouse with
> a scrollerwheel to the xfree86 system by running 'dpkg-reconfigure
> xserver-xfree86' or by manually editing /etc/X11/XF86config-4.
> I've tried both, and either way the new mouse still doesn't work.
> Using dpkg, I used these menu alternatives:
> -psaux as the connection point
> -ImPS/2 protocol
> -With scrollerwheel
I have never seen this. I use
Option          "ZAxisMapping"          "4 5"
for my scroll wheel
> My original XF86config-4 file looks like this (with simple 2-button
> mouse in /dev/ttyS0):

What does your XF86Config-4 file look like NOW. Has it changed?


> Section "InputDevice"
>         Identifier      "Configured Mouse"
>         Driver          "mouse"
>         Option          "CorePointer"
>         Option          "Device"                "/dev/ttyS0"
>         Option          "Protocol"              "Microsoft"
>         Option          "Emulate3Buttons"       "true"
>         Option          "ZAxisMapping"          "4 5"
You might want to comment out this section if you're using a ps2 mouse
and not a serial mouse. Also the error message below complains about
this section.

> EndSection
> Section "InputDevice"
>         Identifier      "Generic Mouse"
>         Driver          "mouse"
>         Option          "SendCoreEvents"        "true"
>         Option          "Device"                "/dev/psaux"
>         Option          "Protocol"              "ImPS/2"
>         Option          "Emulate3Buttons"       "no"
> #
>         Option          "ZAxisMapping"          "4 5"
> EndSection

> The result is that X- will not start, where startx gives this errormessage:
> -----------startx errormessage---------start---------------------
> hjem:~# startx
> X: warning; process set to priority -11 instead of requested priority -10
> XFree86 Version (Debian 4.3.0.dfsg.1-14 20050601051219
> fabbione@fabbione.net)
> Release Date: 15 August 2003
> X Protocol Version 11, Revision 0, Release 6.6
> Build Operating System: Linux 2.4.29-pre2 i686 [ELF]
> Build Date: 01 June 2005
> This version of XFree86 has been extensively modified by the Debian
> Project, and is not supported by the XFree86 Project, Inc., in any
> way.  Bugs should be reported to the Debian Bug Tracking System; see
> <URL: http://www.debian.org/Bugs/Reporting >.
> We strongly encourage the use of the "reportbug" package and command
> to ensure that bug reports contain as much useful information as
> possible.
> Before filing a bug report, you may want to consult the Debian X FAQ:
>        XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
>   plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz
> Module Loader present
> OS Kernel: Linux version 2.4.27-2-686
> (horms@tabatha.lab.ultramonkey.org) (gcc version 3.3.5 (Debian
> 1:3.3.5-12)) #1 Mon May 16 17:03:22 JST 2005 T
> Markers: (--) probed, (**) from config file, (==) default setting,
>          (++) from command line, (!!) notice, (II) informational,
>          (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/XFree86.0.log", Time: Wed Jul 20 20:04:42 2005
> (==) Using config file: "/etc/X11/XF86Config-4"
> Data incomplete in file /etc/X11/XF86Config-4
>         Undefined InputDevice "Configured Mouse" referenced by
> ServerLayout "Default Layout".
> (EE) Problem parsing the config file
> (EE) Error from xf86HandleConfigFile()
> Fatal server error:
> no screens found
> When reporting a problem related to a server crash, please send
> the full server output, not just the last messages.
> This can be found in the log file "/var/log/XFree86.0.log".
> Please report problems to submit@bugs.debian.org.
> XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
>       after 0 requests (0 known processed) with 0 events remaining.
> hjem:~#
> -----------startx errormessage---------stop----------------------
> In the previous thread, "Changing mouse (newbie question)", I was
> given some hints on how to google more efficently, but I have not
> found this problem other places. Please excuse me if I'm asking
> somthing that has been asked before, it was not my intention.
> Thanks for the help in advance, cheers Vegard.
An improperly configured mouse section will result in the "no screens
found" error message. Try what is suggested above and let us know if it
fixes things. Again I am assuming you're using a ps/2 mouse not a serial

Please don't cc: your posting to my personal address.
Thank you.

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: