[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[solved- paritally] Re: external USB acomdata drive



On Thu, Jul 07, 2005 at 08:52:59AM -0700, Pete Hicks wrote:
>I am trying to mount an external 80GB acomdata usb drive on a Sarge
>laptop with a 2.6.12 kernel. I get the following output from hotplug in
>syslog:
>
>Jul  7 08:16:00 moonglum kernel: hub 1-0:1.0: over-current change on port 1
>Jul  7 08:16:00 moonglum kernel: hub 4-0:1.0: over-current change on port 1
>Jul  7 08:16:03 moonglum kernel: usb 4-1: new high speed USB device using ehci_hcd and address 3
>Jul  7 08:16:03 moonglum kernel: ub(4.3): GetMaxLUN returned 0, using 1 LUNs
>Jul  7 08:16:03 moonglum kernel: ub(4.3): resid 8 len 8 act 8
>Jul  7 08:16:03 moonglum kernel: ub: reading capacity: error -5
>Jul  7 08:16:03 moonglum kernel: ub(4.3): resid 8 len 8 act 8
>Jul  7 08:16:03 moonglum kernel: ub: reading capacity: error -5
>Jul  7 08:16:03 moonglum kernel: hiddev96: USB HID v1.10 Device [DMI     ;\205q$* WD800UE-00HCT0  ] on usb-0000:00:1d.7-1
>Jul  7 08:16:04 moonglum usb.agent[6058]:      usbhid: already loaded
>Jul  7 08:16:05 moonglum usb.agent[6045]:      ub: already loaded
>Jul  7 08:16:05 moonglum usb.agent[6045]:      usb-storage: already loaded
>Jul  7 08:16:05 moonglum udev[6139]: creating device node '/dev/uba'
>Jul  7 08:16:05 moonglum udev[6144]: configured rule in '/etc/udev/rules.d/udev.rules[23]' applied, 'hiddev0' becomes 'usb/%k'
>Jul  7 08:16:05 moonglum udev[6144]: creating device node '/dev/usb/hiddev0'
>
>

Turning off hotplug fixed the issue. When hotplug is stopped, plugging
the drive in shows the kernel doing the right thing and recognizing the
drive as sda1, and udev created the device properly.

Now to figure out why...



Reply to: