[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED] Re: Cannot burn audio tracks with cdrecord

Chris Lale wrote:

 Chris Lale wrote:

> I have this problem in both Stable (Sarge) and Unstable with kernel
> 2.6.8-2-386. I have two .wav files (recorded with sound-recorder).
> I can burn a CD with cdrecord using either one of the files, and
> the result is a playable audio CD.
> If I burn a disc using both files, the CD will not play on a
> software audio player or on audio hi-fi equipment. The commands I
> have tried are
> cdrecord -eject -v -tao speed=16 -audio -pad dev=ATA:1,0,0 *.wav
> cdrecord -eject -v -dao speed=16 -audio -pad dev=ATA:1,0,0 *.wav
> cdrecord -eject -v -dao speed=16 -audio -pad dev=/dev/hdc *.wav.
> The same problem occurs using XCDRoast and k3b (which both use
> cdrecord).
> I can burn the .wav files using the -data switch, transfer them to
> a Windoze machine and burn an audio CD sucessfully there.

Thanks to Luis and Rodney.

I went to the Cdrecord FAQ website (http://cdrecord.berlios.de/old/private/man/cdr_readme.html) and found this:

Cdrecord currently only supports Track at once. (For audio files.)

If I use track at once
$ cdrecord -eject -v -tao speed=16 -pad -audio dev=ATA:1,0,0 *.wav
I get a playable audio disc.

If I use disk at once
$ cdrecord -eject -v -dao speed=16 -pad -audio dev=ATA:1,0,0 *.wav
I get a disc not recognised by audio equipment.

This is also true of X-CD-Roast. You must choose "Track-At-Once (TAO)" and not the default "Disk-At-Once (DAO)". This must be how I encountered the problem in the first place - I just accepted the default.

In my original post, I indicated that -tao did not work when I now know that it should do. I think I confused myself because writing in simulate mode (-dummy) produces an error.

Also unexplained is that Rodney seems to have made a successful recording using -dao. Perhaps its something to do with the -useinfo switch?


Reply to: