[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libxml2-dev vs libxml2-devel

I have installed libxml2-2.6.17-2 which isn't in the offciail debian
repository, and I have it successfully installed. Now I need
libglademm-2.4-dev installed which depends on libxml2-dev-2.6.17-2 but
I get this:

libxml2-dev: Depends: libxml2 (= 2.6.16-7) but 2.6.17-2 is to be installed

This is because it tries to install libxml2-dev version 2.6.16-7 from
the official repository. So  downloaded a libxml2-dev as a rpm
package, transform it in a deb package with alien and used
dpkg-scanpackages then apt-get update. The problem is that apt sees
the package obtained from the rpm file as libxml2-devel and not
libxml2-dev and that causes apt to try to install libxml2-dev from the
official repository. So how can I make apt to recognize the package
from the rpm file as libxml2-dev not libxml2-devel.

Reply to: