[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Kernel Panic After Sarge Dist-upgrade To Kernel Image 2.4.27-2-386

Sorry about my mixup.  Found the original reply in drafts; never sent.
This is new reply that is more current.  My reply is bolow:

Leonard Chatagnier wrote:

VFS: Cannot open rootdevice "301" or 30:01
Please append a correct "root=" boot option
Kernel panic: VFS unable to mount root fs on 30:01
Ok, not worried at this time as I have my woody CD's and can do a
rescbf24 to mount woody still installed and correct the lilo.conf but,
here are the related boot messages when attempting rescue:
request_modules_hostadapter]: Root fs not mounted (repeated once)
cramfs: wrong magic
Fat: bogus logical sector size 5202
read_super_block: can't find a reiserfs filesystem on (dev 03:03,
block 64, size 1024)-repeated once
Kernel panic: VFS unable to mount root fs on 03:05
Now I'm worried. Note: I don't have a reiserfs file system, only an ext3 fs since day one on all partitions.

If I understand, you have a dual-boot system, with Sarge and Woody.

Sarge's boot is hosed, but you've tried to boot off the Woody
installation CD into the Woody installation, and it fails also.

Is this correct?
Yes, it did originally.  However, I checked around and found the
right syntax for boot option and was finally able to boot woody,
but sarge 2.4.27-2-386 stil has kernel panic.

If it were me, I'd boot off a LiveCD, such as Knoppix or Kanotix, then
run cfdisk to see what partitions are defined. I'd mount the / partition
on the hard drive, and look to see what /etc/fstab says, and take a look
at the initrd issues you mention. My gut instinct (not having adequate
info), is that either your partition table is scrambled, your drive is
failing, or you're not feeding the correct parameters to the Woody CD.

The output of cat /etc/fstab, cfdisk and lilo.conf are shown at the end
of this message.  I did add the initrd= into vmlinuz as the aptitude dist-
upgrade configure put something in that did't work; can't remember exactly what it
said now but it was the last thing the configure did before moving on from lilo. After a lot of research and reading the release issues I did another aptitude dist-upgrade with
the options specified in the release and the only error was in installing setiathome
an the ksetiathome which I don't need. I even tried putting the actual path to the /boot/sarge-initrd.img for initrd= but nothing worked. I even posted to an email buddy
of mine who had a similar kernel panic issue on the list, with the entry shown in my
lilo.conf and it worked for him.
I also thought the /Solaris entry in linux Swap was an error.  When I entered single
user mode to correct it, I found the same data for type 82 linux swap so didn't write
out anything.  This must be something new in sarge as I don't remember it being there
in woody. I really need your help here as I've spent the last days and nights searching
for a solution without any success.  If you don't mind, please copy my email address as
its much easier to reply than copying the post from the web.
Thanks for your help,

Leonard Chatagnier

Kent West
Technology Support
/A/bilene /C/hristian /U/niversity

ChatagnierL-Home:/# cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>               <dump>  <pass>
/dev/hda1       /               ext3    errors=remount-ro       0       1
/dev/hda5       none            swap    sw                      0       0
proc            /proc           proc    defaults                0       0
/dev/fd0        /floppy         auto    user,noauto             0       0
/dev/cdrom      /cdrom          iso9660 ro,user,noauto          0       0
/dev/hda2       /usr    ext3    defaults                        0       2
/dev/hda3       /var    ext3    defaults                        0       2
/dev/hda6       /home   ext3    defaults                        0       2
/dev/hda7       /temp   ext3    defaults                        0       2
/dev/hda8       /tmp    ext3    defaults                        0       2
ChatagnierL-Home:/# cfdisk
                                                      cfdisk 2.12p

                                                  Disk Drive: /dev/hda
                                            Size: 13676544000 bytes, 13.6 GB
                                  Heads: 255   Sectors per Track: 63   Cylinders: 1662

     Name              Flags             Part Type       FS Type                   [Label]               Size (MB)
     hda1              Boot, NC           Primary        Linux ext3                                        1019.94
     hda2                                 Primary        Linux ext3                                        4507.46
     hda3                                 Primary        Linux ext3                                        4606.16
     hda5              NC                 Logical        Linux swap / Solaris                               386.59
     hda6              NC                 Logical        Linux ext3                                        1538.13
     hda7              NC                 Logical        Linux ext3                                        1431.20
     hda8              NC                 Logical        Linux ext3                                         180.96

ChatagnierL-Home:/# cat /etc/lilo.conf
# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# ---------------       `install-mbr(8)', `/usr/share/doc/lilo/',
#                       and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt', or install a new kernel.  The |
# | computer will most likely fail to boot if a kernel-image      |
# | post-install script or you don't remember to run `lilo'.      |
# |                                                               |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.

# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.
#    bios=0x81

#    bios=0x80

# Specifies the boot device.  This is where Lilo installs its boot
# block.  It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.

# Specifies the device that should be mounted as root. (`/')
# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller.  Using `compact' is especially recommended when
# booting from a floppy disk.  It is disabled here by default
# because it doesn't always work.
# compact

# Installs the specified file as the new boot sector
# You have the choice between: bmp, compat, menu and text
# Look in /boot/ and in lilo.conf(5) manpage for details
install=/boot/boot-menu.b	(Note: This gives me a text interface but so does "bmp"

# Specifies the location of the map file
map=/boot/map	(Note: tried several things here also but still get text based lilo and have to hit scroll lock for graphics)

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration.  If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well.  Please RTFM `install-mbr(8)'.
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.

# You can put a customized boot message up if you like.  If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress.  `single-key' goes with the `alias' lines in the
# `image' configurations below.  eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
# message=/boot/bootmess.txt
#       prompt
#       single-key
#       delay=100
#       timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
# vga=ask
# vga=9

# Kernel command line options that apply to all installed images go
# here.  See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
# append=""

# Boot up Linux by default.

       initrd=initrd.img	(Note: there is a link in / to the actual /boot/initrd.img/sarge.img so it should work)
#       restricted

#       restricted

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
# other=/dev/hda4
#       label=HURD
#       restricted
#       alias=3

Reply to: