[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Newly installed Sarge: (1) halts at 8529A IRQ 7 (2) cannot start gdm: X server is missing.

On Mon, Jun 13, 2005 at 04:06:55PM -0300, Fernando Cacciola wrote:
> Hello People,
> I had Knoppix 3.8.1 intalled on an old AMD K7 Duron 700 with 128Mb RAM, all 
> OnBoard except the wireless eth card.
> It worked OK.
> Then I installed Sarge from scratch (keeping the Knoppix partitions but 
> re-installing the Sarge FS on it) using a netdist CD.
> The CD part went very smoothly, but when it first booted from the HD I got:
> (1) Spurious 8529A interrupt IRQ7; and it halted.
> Using another PC I looked that up in google and saw that it was probably 
> related to the ACPI code on the 2.4 Kernel.
> So I tried with the 2.6 Kernel but I had 2 problems:
> (2.a) DHCP didn't work (and I tried several times) (but it did for Kernel 
> 2.4)
> (2.b) Leaving net unconfigured, it stops at some point saying that it 
> couldn't locate the Kernel image for 2.6. Either it is not on the netinst CD 
> or it was trying to get it from the internet (and of course it failed)
> So I had to stick with the 2.4 Kernel.
> I tried adding "linux acpi=off" on the CD prompt and installing all over 
> again but I still had the IRQ problem.
> So I was about to install Knoppix back again when I read in its help window 
> to try: "knoppix acpi=off noapci pci=bios" for "broken BIOS"... I figured my 
> PC could have a broken BIOS so I tried those parameters with the debian 
> netinst CD.
> It then passed the first HD boot and moved on with the installation.
> Yet, after it finished downloading and configuring all the packages I got a 
> error saying that "Some packages couldn't be installed"... but it didn't say 
> which ones, so I just ignored it and finished the installation.
> When I rebooted (for the first time with the system apparently fully 
> installed) I got back the IRQ problem, so I just rebooted again and again 
> until it passed (I eventually determined that the message always apperared 
> but 4 out of 5 times it also halted)
Did you use "pci=bios" when you rebooted?  You can put that into 
/etc/lilo.conf or /boot/grub/menu.lst depending which boot loader you 

> So I typed "apt-get -f installed" and it download XFree86-common and spend 
> quite a lot of time updating packages.
> I though it was it, but after I rebooted (about 5 times to get past the IRQ 
> halt); I still get the console prompt and the error that the X server is 
> missing.
> Effectively, xinit is trying to execute "/usr/bin/X11R6/X" but I don't have 
> that X on my system.
> Any clues?
apt-get install xserver-xfree86
apt-get install x-window-system

I cannot believe that God plays dice with the cosmos.
		-- Albert Einstein, on the randomness of quantum mechanics

Reply to: