[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Woody-No Mouse, Sarge-OK


On Fri, Jun 03, 2005 at 02:01:38PM +0000, Leonard Chatagnier wrote:
This problem started after removing devfsd on Sarge to overcome a conflict between udev and devfs. It just took a while to realize it as woody is not booted very often. So, I reinstalled devfsd and recreated the symlink ln -s /dev/mouse /dev/psaux. Although this hasn't changed anything when
That's backward, it should be ln -s /dev/psaux /dev/mouse.
Now you probably have two symlinks pointing at each other.
ls -l /dev/psaux /dev/mouse

If psaux is a symlink:
rm /dev/psaux
mknod /dev/psaux c 10 1

I'm doing this under woody without mouse working so it wont get mixed up with sarge.
Thanks very much for the info about the backward symlink and mknod which I've never used.
I asked a friend to send me his copy of the above psaux link, because I've got them backward
before but he has been out of the pocket so I tried it myself and naturall got it wrong. However, mouse still not working under woody. Here's what I did following your instruction
as I understood them:

# rm /dev/psaux
Rm: cannot remove `/dev/psaux/: no such file or directory(note:done after already rm when
kbd screwed up doing mknod)
# mknod /dev/psaux c 10 1
# ls -l /dev/psaux /dev/mouse
lwrxwrxwrx  1 root  root     10 June 4 08:20 /dev/mouse -> /dev/psaux
crw-r--r--  1 root  root  10, 1 June 4 10:03 /dev/psaux
The above copied by hand as I don't know how to copy and paste without mouse and gpm working. However, its basically what the terminal results were, but still no working mouse.
At least the symlink is there now and I've rebooted but no mouse.  Hope you have more things to
try and thanks for your help.  I thought surely the mouse would come back after getting the symlink
down correctly.
Leonard C

Reply to: