[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Strange: Linux boots off a deleted partition [Was Re: Please help: Accidentally wiped off the whole hard disk!!!]

Deboo ^ wrote:
I did a trial on a smaller hard disk. Installed knoppix on it,
rebooted from the hdd to test it. Rebooted again from the Live CD and
(after taking down the Linux partition info) deleted the partitions
and created just one partition, and changed the type to bf (Solaris) -- the same thing which happened with the other hard disk.

Now I tried booting off the hard disk just to check and it booted
without problems. Strange because when I check with fdisk, this is
what I see:

deboo@knoppix:~$ sudo fdisk -l /dev/hdc

Disk /dev/hdc: 3227 MB, 3227148288 bytes
255 heads, 63 sectors/track, 392 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
   /dev/hdc1               1         392     3148708+  bf  Unknown

There was one Linx partition and a Swap partition which I deleted.
Can someone explain this behavior? If this hard disk boots alright
then why doesn't the other hard drive boot when the same thing
(accidentally) happened to it?


The most obvious explanation is that the swap partition on your other
drive started at the first cylinder, but life is usually not that simple.

Beyond that is guesswork, but in your first post you mentioned something
about having two drives when you thought only one was installed.  You may
still not understand some problem in your original coinfiguration, making
adequate duplication of the original problem difficult at best.

It's not clear what you are trying to accomplish.  In another post you
claim to have the necessary partition table parameters to fix your

Reply to: