[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble with LILO...



Thomas Chadwick wrote:
I have kind of a unique situation, and googling for help hasn't really turned up anything that's applicable, so I'm turning to the mailing list for some help. Here's the run-down:

Installed Debian (Woody stable) on a fairly old computer. I wanted to use a huge (120GB) harddrive, but the BIOS doesn't support huge IDE drives, so I did the following:

Installed Windows 98 on a 545MB HDD (Master on the Primary IDE Channel, aka /dev/hda1). Installed Debian on a 120GB HDD (Master on the Secondary IDE Channel, aka /dev/hdc1).
Used loadlin to boot into Debian Linux.

This has worked great for me. I simply told the BIOS there was only 1 HDD installed (the 545MB one), and it happily booted into Windows, which then happily ran loadlin, which happily booted Debian. The kernel, which talks to the IDE controller directly, had no trouble finding, mounting, and using /dev/hdc1.

However, I recently upgraded the MOBO, and since the BIOS on the new MOBO supports huge IDE drives, I'd like to get rid of the funky boot process described above, and boot directly into Linux using LILO.

From everything I read, the boot device does not have to be /dev/hda, so I
figured I'd leave the 120GB HDD at /dev/hdc (and uninstall the 545MB drive altogether). So... I created the following /etc/lilo.conf

boot=/dev/hdc
root=/dev/hdc1
lba32
vga=normal
delay=100
image=/vmlinuz
initrd=/initrd.img
read-only

I ran lilo, which didn't have anything interesting to say other than the fact that /dev/hdc is not the 1st harddrive.

I also ran "lilo -A /dev/hdc 1" to mark the 1st partition, /dev/hdc1, as bootable.

Finally, I shutdown the machine, unplugged the 5454MB harddrive, powered up, and, instead of booting into Debian, I get:

L01 01 01 01 01 01 [ad nauseum]

Any clue what I did wrong?

-Tom

P.S. If I re-install the 545MB drive, I can still boot Debian just fine using the loadlin mothod.



I've run into this problem (bug?) many times, and the only consistent
work around I've found is to temporarily disconnect drives other than
one containing the root partition, boot from a rescue floppy and use
the linux command line parameter root=/dev/[...].  In your case I would
use the following command line (boot:) linux root=/dev/hdc1

There is probably a more elegant (correct?) way to do it, but I've not
found it.




Reply to: