[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

installing X causes RAID to fail


 I'm wondering if anyone else has come across this problem...

 I've been trying to get RAID up and going (consistently) for a few days
now. After attempting many things such as installing with/without a
desktop, changing partition sizes and changing the number of partitions,
I've narrowed down that installing X and a desktop environment is causing
RAID to fail at boot. (i.e. If I just do a base install and configure
RAID through the installer, it will work.)

 However, if I install X and a desktop environment either through the
installer or afterwards, the RAID arrays - except md1 (/boot) - will not
mount. This result is mimiced in /proc/mdstat which only shows the one

 The loadmodules file in the initrd.img image show the following modules
being loaded at boot and looks identical to this before installing

 modprobe -k vesafb > /dev/null 2>&1
 modprobe -k fbcon 2> /dev/null
 modprobe -k unix 2> /dev/null
 modprobe -k raid1
 modprobe -k ata_piix
 modprobe -k aacraid
 modprobe -k sc_mod

 The /etc/default/mdadm file looks like this and again is the same as
before installing x/desktop.


 The /etc/mdadm/mdadm.conf file - which again looks identical - is like this:

 DEVICE partitions
 ARRAY /dev/md7 level-raid1 num-devices=2 UUID=[a bunch of hex stuff]

 [and then continues with the "ARRAY" and "devices" lines as you would
expect for each array matching it with the two corresponding partitions.]

 As a note on this file, I've tried regenerating it (mdadm --detail --scan
>> /etc/mdadm/mdadm.conf) and having the first line read "DEVICE
/dev/sda* /dev/sdb*" which doesn't help.

 I've tried rebuilding the initrd.img image - still no improvement.

 The Grub device.map and menu.lst files look identical to what they looked
like before the x/desktop installation.

 The error that occurs at boot for each of the unmounted arrays is like:

 fsck.ext3: No such file or directory while trying to open /dev/md1
 The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains and ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate
 e2fsck -b 8193 <device>

 Any help would on why this happens after installing x/desktop would be
greatly appreciated.

I'm using sarge with kernel 2.3.6-2.386

 Thank you..

Reply to: