[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lost /dev/modem Symlink After Purging Udev And Reinstalling-Solved

Thanks to all who offered help; there were more than one possible solution, but had solved the problem before reading it. Thanks, Justin for your to the point suggestion. The solution: Reinstalling udev* using the woody, 2.4.18-bf2.4, allowed the 2.6.8-2-686 KI to boot normally but wvdial still couldn't find /dev/modem. Reinstalling the hcfpci*.deb modem driver fixed the
udev problem allowing udev to recognize my modem.  Thanks again to all.

Leonard Chatagnier wrote:

Leonard Chatagnier wrote:

This request for help is being reposted as no one offered any help.
Please, would someone respond with some help, even if its just a link
offering a solution that a relative newbie can implement.

After Purging udev including rming the entire /etc/udev directory and
reinstalling to fix a sound problem I have
to create the modem symbolic link, ln -s /dev/ttySHCF0 /dev/modem every
time I boot up.  I've tried
ChatagnierL-Home:/etc/udev/scripts# /etc/init.d/udev restart
Recreating device nodes...done.
After rebooting, still no /dev/modem and have to create symlink again
ChatagnierL-Home:/etc/udev/scripts#  /usr/bin/udevtest /dev/modem
version 056
looking at '/dev/modem'
sysfs_open_class_device_path failed
Googled for above message and found 7 items concerning older versions of
udev with pages of script that I wouldn't
dare try.

There were 2 or 3 files in /etc/udev/rules.d dir that were no recreated
after reinstalling udev that goes something like:
hfcpci.conf and 10 or 50sound.rules.  The hfcpci.conf is probably
pertinent to the problem.  How can I recreate it?

You mention that you installed your driver from hfcpci~1.deb, which tells me that you downloaded a driver from the manufacturer. Nothing in /etc/udev
belonging to the hfcpci package should have been deleted, but if it was,
you should reinstall that package to get those config files back.

Somewhere above I mentioned removing all of the udev subdirectory before reinstalling udev. I'll reinstall hfcpci~.deb in the 2.6.8-2-686 KI if I can boot it. I uninstalled udev* and purged udev* and since then the 2.6.8 kernel wont boot up properly. Hda2(/) gets mounted but hda3 thru hda8 has an inode problem and it asks me to fix it manually with e2fsck -b 8193 <device> but get error message using 2fsck -b 8193 /dev/hda3. I need help here to fix the inode problem. I did get a runlevel 1 boot but using cntrl D to continue booting runlevel 2 locked at starting syslogd. Right now I apt-get install udev* under the backup 2.4.18-bf2.4 KI to see if that will fix it. The 2.4.18-bf2.4 KI is working fine in spite of not having devfs or udev installed. I suppose
that's the way it works in debian but confuses me.

Considered running the script inputdev.sh, read sh man and info but
couldn't determine which option to use.  Never have run a script before
but it seems to use Debian I going to have to do it. Could someone clue
me in if this is the
correct script to use and the proper switch to use.  I am a relative
newbie and not a programmer, just a user.
I've also read the udev manual and googled on the subject, and its over
my head.

? A quick solution is desirable as my system is fully functional

otherwise(until the next upgrade/dist-upgrade anyway).  I'm using
kernel-image 2.6.8-2-686 an upgrading under testing with udev version
.056-2 installed.
There is no entry regarding /dev/modem, only a capi entry, in the
udev.rules file or in the devfs.rules file.

Thanks for any help,
Leonard Chatagnier

Reply to: