[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Custom Kernel 2.4.18 = No Loadable Modules?

Hi All,
    I started with a Debian Woody Distribution 3.0r5 where the kernel version is 2.2.20.  I couldn't compile the Omnivision ov59x driver for a webcam and so based on the FAQ for the driver, I decided to upgrade to kernel 2.4.  I found some instructions for this, and after a few tries, I now have a semi-working system using kernel version 2.4.18.  My problem is that I don't seem to have any modules available for loading.  The /lib/modules/2.2.20 is full of *o object modules under subfolders like net and misc, but my /lib/modules/2.4.18 has no such files.  I tried compiling the driver, and it created a ov59x.o file that I managed to get into /lib/modules/2.4.18/kernel/drivers/usb, but now that's the only object file available.  When I built the kernel, I downloaded and untarred the 2.4.18 source, then did :
ln -s /usr/src/kernel-source-2.4.18 linux
cd /usr/src/linux
make menuconfig        # selecting several supported modules including my network card and usbcore, usb-uhci...
make-kpkg kernel-image   
cd /usr/src
dpkg -i kernel-image-2.4.18_10.Custom_i386.deb
rebooted to a working kernel
However, modconf shows no available modules
I tried doing a make modules_install, but all compiles complained that there was nothing to do.  It attempts to look in directories like /usr/src/kernel-source-2.4.18/drivers/usb where there are valid source files like usbcore.c, but it says :
Make[2]: Nothing to be done for 'modules_install'
I've seen a lot of newsgroup suggestions regarding this and the need to upgrade modutils, but my modutils version is 2.4.15-1 so I'm wondering what else to look for.
Thanks for any help,
Tony Vandiver

Reply to: