[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dpkg/apt-get broken, seg fault on "updating MIME db"

I've tried every combo of removing, install -f, dpkg -a --configure etc. that 
I can think of. Seems to semi-interfere with most installs/upgrades. I have 
tried, and google'd for weeks. Now I guess I'll admit defeat and ask here.
planner and bluefish are stuck...planner first, then bluefish this week...

Output is below (then more output below that):
Unpacking replacement planner ...
/var/lib/dpkg/info/planner.postrm: line 34: 13902 Segmentation 
fault      /usr/bin/update-mime-database /usr/share/mime
dpkg: warning - old post-removal script returned error exit status 139
dpkg - trying script from the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: line 39: 13908 Segmentation 
fault      /usr/bin/update-mime-database /usr/share/mime
dpkg: error processing /var/cache/apt/archives/planner_0.13-0.3_i386.deb 
 subprocess new post-removal script returned error exit status 139
/var/lib/dpkg/tmp.ci/postrm: line 39: 13914 Segmentation 
fault      /usr/bin/update-mime-database /usr/share/mime
dpkg: error while cleaning up:
 subprocess post-removal script returned error exit status 139
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

So, I run an strace /usr/bin/update-mime-database, and the only odd things I 
see in it are:
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or 
open("/lib/tls/libc.so.6", O_RDONLY)    = 3

Which Google seems to think is any number of random things, none of which seem 
to pertain to me.

Any ideas?

Reply to: