[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

K3b says "no suitable writer found" when run as normal user

I hope somebody can help me with the following problem. K3b doesn't find a 
"suitable writer" if I run it as a normal user. This problem appeared 
after I upgraded to kernel(-image) 2.6.8-2-k7.  
I have no idea why it doesn't detect the writer, it detects the drive as 
reading device only. 
I use cdrecord (Cdrecord-Clone 2.01a34) and a cdrecord -prcap (run as 
normal user) detects the writer: 
scsidev: 'ATA:1,0,0' 
devname: 'ATA' 
scsibus: 1 target: 0 lun: 0 
Warning: Using badly designed ATAPI via /dev/hd* interface. 
Does read CD-R media 
Does write CD-R media 
Does read CD-RW media 
Does write CD-RW media 
The permissions of files and devices are: 
brw-rw-rw-  1 root cdrom 22, 0 Mar 14  2002 /dev/hdc 
-rwsr-xr--  1 root cdrom    133 Aug 26  2004 /usr/bin/cdrecord 
-rwsr-xr--  1 root cdrom 347180 Aug 26  2004 /usr/bin/cdrecord.mmap 
-rwsr-xr--  1 root cdrom 347212 Aug 26  2004 /usr/bin/cdrecord.shm 
(cdrecord is installed suid root) 
K3b detects cdrecord.mmap 
If I run k3b as normal user, k3b says that the writer can write CD/RWs but 
not CDs, if I run k3b as root, k3b says it can also write CDs. 
I think the problem is really strange. K3b is really user-friendly as long 
as it works, but if it stops working it is worse than 
windows-applications. I installed it to make windows users able to use the 
linux box. 
Any suggestions what I configured wrong? 

+++ GMX - Die erste Adresse für Mail, Message, More +++

1 GB Mailbox bereits in GMX FreeMail http://www.gmx.net/de/go/mail

Reply to: