[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /dev/input/mice doesnt works

On Tue, Apr 12, 2005 at 09:21:57AM -0300, du linux wrote:
> I'm using ImPS/2 , and it doesnt works...its strange...cause I made it
> work in Xorg (with slackware) , but with XFree nop.
> On Apr 11, 2005 6:48 PM, Bill Marcum <bmarcum@iglou.com> wrote:
> > On Mon, Apr 11, 2005 at 08:57:00AM -0300, du linux wrote:
> > > My mouse is usb optical mouse...that worked in Xorg with slackware
> > > 10...and I tried to modprobe mousedev and hid.
> > > When I do cat /dev/input/mice with these modules loaded...it shows me
> > > nothing...even if I move my mouse....but when I do cat /dev/psaux and
> > > move my mouse...it show me a lot of strange things....and then I puted
> > > it on XF86Config-4 and started the X server.
> > > But my mouse got freak...starts to click everywhere and doesnt obey me :)
> > > So I realize that the /dev/psaux doesnt works for me...but when I try
> > > /dev/input/mouse is doesnt shows nothing.
> > >
> > What mouse protocol do you have in XF86Config-4?  Usually it should be
> > PS/2 for a mouse with two buttons and no wheel, ImPS/2 for two buttons
> > and a wheel, or ExplorerPS/2 for more than 2 buttons and a wheel.
> > 
> > --
> > "I deleted a file from my PC last week and I have just realized that I
> > need it. If I turn my system clock back two weeks will I have my file
> > back again?"

I have USB optical mouse too :-)

Debian offers many choices and sometimes you need to know what are the

It looks to me slackware is using 2.4 Kernel with devfs.

On my system, I use sid with Debian 2.6 kernel while loading mousedev
through etc/modules .  Oh, I use udev.  So in my system, device location can be foubd
/dev/input/mice and /dev/psaux.

$ sudo cat /dev/psaux |hd
$ sudo cat /dev/input/mice |hd

Both works nicely :-)


Reply to: