[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mounting fat32

Dan Stefan Rundberget wrote:
> I 've got Sarge and WinXP. I have all my personal stuff on one seperate
> harddrive (hdd, with fat32) and I'm trying to mount it under ~/danstefan.
> I've tried: # mount -t vfat /dev/hdd /home/danstefan/danstefan
> I get this wrong fs type or to many mounting points error.
> And I've added this line to /etc/fstab:
> /dev/hdd /home/danstefan/danstefan vfat defaults,user 0 0
> KDiskFree shows the line, but when I click tan select mount  i get the
> same error!
>  With this one I have 5 lines in /etc/fstab, so I can't have to many.
> Trying to migrate frame Mandrake (eanted to try one of those truly free
> distros) it mountd perfect with manrakes buildin, and it worked! I
> did'nt get eny errors! Wel itæs the same disc, only the distro has changed!
> Please help!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
> PS
> Does eny one know why its called vfat instead of fat32?
> I hope my englis is'nt too bad. (I'm Norwegian)

/dev/hdd designates an entire hard drive. You have to mount a partition
from that drive, such as /dev/hdd1 or /dev/hdd2 etc.

I believe vfat stands for virtual fat (or something along those lines),
where you can have long filenames - as opposed to 'msdos' where the
filenames are restricted to the 8.3 format. vfat can mount either FAT16
or FAT32 file systems.


Reply to: