[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Depends: perl but it is not installable

> > $ perl -v
> > This is perl, v5.8.4 built for i386-linux-thread-multi
> I see that one of the errors is:
> libcompress-zlib-perl: Depends: perl (>= 5.8.4-6) but it is not installable
> There are others for earlier versions of 5.8.4.  What does "apt-cache
> policy perl" say?  If, for some reason, apt can't upgrade to this

# apt-cache policy perl
  Installed: (none)
  Candidate: (none)
  Package Pin: (not found)
  Version Table:
     5.8.4-6 1000
        600 http://mirrors.sunsite.dk sarge/main Packages
        500 http://mirrors.sunsite.dk sid/main Packages

> version or later, it might bollux up everything else.  It might also
> be useful to try installing a few of the packages at a time.  Maybe
> start with spamassassin or gs-gpl.

Then I get E: Broken packages

If I try with Perl I get this:

# apt-get install perl
Reading Package Lists... Done
Building Dependency Tree... Done
Package perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  perl-base libcgi-perl
E: Package perl has no installation candidate
Any idea?


Reply to: