[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Marvell Yukon Gigabit Ethernet card not detected

I am using a net install version of sarge and
everything runs fine right until it cannot detect this
network card.   Google turned up a few threads, but
none of the solutions seemed to work for me since I
don't know how to load the "sk98lin module" with the
CD install.

The system I just installed has an onboard gigabit ethernet on the motherboard that is a Marvell that uses the same driver. I was doing a CD install, not a net install, so I don't know if you'll be able to do this, but FWIW:

I was installing Woody with the 2.4 kernel, and it didn't detect the card. So I got through the install (you'd have to try to break out to a prompt) and used a driver off of a floppy. I got the driver from the ASUS site, on the support page for the p5p800 motherboard. It worked fine, just by following the instructions that came with the download, totally cookbook. There's a script that does everything you need to get it running the first time. Once I got the thing working, then I added it into the permanent configuration in /etc/network.

So you could try that. The rub is that the script compiles the driver module, which means you'd have to have gotten far enough through the install to have a compiler, and I don't know if you will be able to do that with the net installer.

I could send you the binary, but I have no idea if that will work. Can anyone say how portable those are? Mine is compiled on a p4 system with a 2.4 kernel. (2.4.18?)


On the road to retirement? Check out MSN Life Events for advice on how to get there! http://lifeevents.msn.com/category.aspx?cid=Retirement

Reply to: