[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel panic: VFS

-installed a broken udev?
-corrupt filesystem?

If filesystem is corrupt, is there any solution to avoid losing all the data?
The system has been working without problems for long time. What could be
the reason for this to happen without having installed anything or experimented.

> I switched off my laptop after a long day of work. Next day, when I
> tried to turn it on, Linux could not be started. These are the messages
> that I have when starts:
> VFS: Can?t find ext2 filesystem on dev ide0(3,4)
> FAT: bogus logical sector size 56904
> VFS: Can?t find a valid FAT filesystem on dev 03:04
> Unable to identify CD-ROM format
> FAT: bogus logical sector size 56904
> (...)
> pivot_root: No such file or directory
> /sbin/init: 426: cannot open dev/console : No such file
> Kernel panic: Attempted to killed init!

> I don?t understand why this is happening: I didn?t install any new
> program on the previous session. I didn?t change anything in the config
> files or move files either. When I turn the laptop on the LILO menu
> comes up as usual. I have also Windows 98 installed. I don?t have any
> problems to start Windows, however.
> I tried to use the ?rescue? mode in the Debian CD. I also passed as
> parameter root=/dev/hda4. It didn?t work though; this is the output:
> ...
> Partition check:
> hda: hda1 hda2 hda3 hda4
> apm: BIOS version 1.2 Flags
> apm: disable on user request (?)
> request-module [block-major-58] Root fs not mounted
> VFS: Cannot open root device 3a:05
> Kernel Panic: VFS: Unable to mount root fs on 3a:05
> As a way around, I tried to use the Intallation CD, option ?Mount an
> Existing Partition?, I selected /dev/hda4 from a list of choices, and
> this was the response:
> ?Mount Failed: No such file or directory?.
> I have been using long time a kernel 2.4.26. The base system?s been
> updated to ?testing?, but never had problems. I searched on the
> Internet/Debian mailing for similar problem, but none of the results had
> common circumstances.
> I suppose it?s not a problem with the kernel, because I?d have been able
> to boot with ?rescue?. I have no clue what the problem can be. I?d much
> appreciate any hint or thoughts from anyone.
> Thanks a ton.
> David.


Join Excite! - http://www.excite.com
The most personalized por tal on the Web!

Reply to: