[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SOLVED (sort of): Setting up USB scanner

On Sat, Jan 22, 2005 at 11:28:16PM -0800, G. Crimp wrote:
> Hi,
> I'm trying to wade through the process of getting USB working so I can use a
> hand me down Epson 1250 Photo USB scanner on woody system, with kernel 2.4.18
> that I've configured and compiled myself.
> I've been to backports.org for the latest versions of libusb, sane-utils,
> and assorted dependences.
> I can get sane-find-scanner to find the beast (vendorID 04b8, productID 010f
> at /dev/usb/scanner0, or libusb:001:002) but can't get any of xsane,
> xscanimage, scanimage, or the gimp (using xsane) to find the scanner.
> If I try
> 	$ xsane
> by itself, an info box pops up telling me "scanning for devices".  After a
> couple of minutes I get "xsane: no device available"
> If I try 
> 	$ xsane plustek:/dev/usb/scanner0
> the error "Failed to open device `plustek:/dev/usb/scanner0': Error during
> device I/O" is eventually returned.
> Even though this is an Epson scanner, I have been using
> /etc/sane.d/plustek.conf to try and configure it.  A couple of web sources
> have pointed out that this particular model of Epson requires the plustek
> backend to sane, rather than the epson one.  
> Any pointers on what I am doing wrong, or thoughts on what I should 
> try next ?  
> Thanks,
> Ger

For what it's worth, this is working now.  To summarize the problem, even
though sane-find-scanner was finding the device, none of the scanning
programmes could see it.

Re-reading "man sane-usb", I noticed that the libusb method of accessing the
scanner wouldn't work if the scanner.o module was loaded.  Unloading the
scanner module, I tried again using libusb in the plustek.conf file, and got
things to work.

So, I've got the scanner working, but, I still don't know why it wouldn't
work with the scanner kernel module.

Thanks for all the suggestions.


Reply to: