[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ide-atapi tape drive and device files


Thanks for answering.  I followed your advice and used mknod to create
ht0, but I still get this response from an mt command:

mt: dev/ht0: No such device

/dev/ht0 is there now, major 37, minor 0.  Any other ideas?


On Tue, 2005-01-25 at 20:17 +0100, Christopher Pharo Glæserud wrote:
> Mark Barnes, 
> > There is no device ht0 in my /dev directory.  I ran the script MAKEDEV,
> > following some hints in the
> > file  /usr/src/kernel-source-2.4.27/Documentation/ide.txt, but that
> > didn't seem to do the job either.  I'm running Debian testing here.  Can
> > anyone point me to some documentation that'll tell me how to create the
> > device ht0, and allow me to access an ide-atapi tape drive seen as hdd
> > by the kernel?  Thanks.
> Try
> cd /dev
> mknod ht0 c 37 0
> (create node named ht0 as a character device with MAJOR 37 and MINOR 0
> as per Documentation/devices.txt from the kernel sources.
> hdd will fail, as /dev/hdd is a block device and not a character device.
> -- 
> regards,
> Christopher Pharo Glæserud

Reply to: