[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound broken with new kernel.

Mason Loring Bliss wrote:

Hi, all!

I'm running Sarge on my Toshiba Tecra 8100. It has a YMFPCI sound system.

ALSA doesn't work at all for me. However, OSS works. I have no problem
generating noise under kernel 2.4.27. Sound under 2.6.8 is different...
When sound should start playing, my speakers click, and that's it. Through
random luck I've had sound under 2.6.8 a couple times, but it hasn't worked
for a week or so now.

Unfortunately, I can't run 2.4 as my normal kernel on this box because of
lock-ups with my wireless card and issues with mouse input breaking, along
with a general fantastic sluggishness which makes the machine just about
unusable. So, I'm largely stuck using 2.6.8. I would love to have sound,

Can someone suggest diagnostics I might try to learn more about what's
happening here? I've tried building a kernel without any ALSA stuff built
in, but for some reason the resulting kernel packages don't install a
/boot/initrd.img-2.6.8-foo for me, and I can't successfully boot. (I
took my existing kernel config from the Sarge 2.6.8/686 package as a
base, chopped out ALSA-related drivers, and built it by invoking make-kpkg

Thanks in advance for clues. If my sound card works flawlessly under 2.4, I
can't imagine it's out of the question for it to work with 2.6...
I kinda doubt it is related, but I just fixed sound on a Dell by adding acpi=noirq to the kernel line in /boot/grub/menu.lst.

Give that a go. Here's the reasoning:

Regards, Upayavira

Reply to: