[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dell PowerEdge 2850 kernel panic.

Michael Bellears wrote:
Debian-Installer RC2 (Downloaded 28/12/2004).

3 x 72.8 SCSI drives in Raid 5.

Install successfully detects raid controller, and allows partitioning
and installs boot-loader(Grub) successfully - but upon reboot, I get a
kernel panic:

Pivot_root: No such file or directory
/sbin/init: 426: cannot open dev/console: no such file
Kernel panic: Attempted to kill init!

Any help is greatly appreciated.


I loaded one of these a few months ago. If I remember correctly the problem was that mkinitrd probed and found the "megaraid" module. The problem is that the new kernels use megaraid_mbox and megaraid_mm so it fails because there is no megaraid module. I tried a 2.4 install and that version of megaraid didn't work with the 2850 (worked fine with 1550,1650,1750,2650 though).

I fixed it by chrooting into the _real_ filesystem prior to rebooting after the install. From there I just added the correct modules to /etc/mkinitrd/modules and re-installed the kernel (just to generate a new ramdisk).

After this it found the file system at boot time but I had trouble with hwclock... it would hang here indefinitely. I had to hack /etc/init.d/hwclock.sh and /etc/init.d/hwclockfirst.sh and add --directisa to the options passed to hwclock. After that all was fine.

It sounds like more work then it was... it was actually a quick fix. No disrespect to the maintainers of initrd-tools, but it's a mess these days. It's tries to be very intelligent and in most cases it works fine, but with all the SATA (libata) and RAID stuff out there it seems to have difficulties. Most problems can be worked around with some light prodding.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: