[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

mplayer in the console

I tried to play movie in the console with mplayer. I have radeonfb compiled 
into the kernel and works. I tried to start mplayer in two ways:

mplayer -vo fbdev /dev/fb0 movie.avi


mplayer -vo fbdev -fb /dev/fb0 movie.avi

but neither works, and these are the last few lines that mplayer reports:

Starting playback...
VDec: vo config request - 608 x 256 (preferred csp: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: using unscaled Planar YV12 -> BGR 24-bit special converter
VO: [fbdev] 608x256 => 608x256 BGR 24-bit
FATAL: Cannot initialize video driver.t

FATAL: Could not initialize video filters (-vf) or video output (-vo).

alsa-uninit: pcm closed

Exiting... (End of file)

What could be the problem?

P.S. In X mplayer works fine.

Reply to: