[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get problems for unmet dependencies

roberto wrote:
i have two main questions:

1) since someone else installed Debian on this pc i am working on, i need to know how to check
which version i am currently using of Debian (stable/testing/unstable). These all infos i got from

	Linux 2.4.21 i686 unknown

2)i try to install the following packages via

	#apt-get install <package-name>

 1) tcl8.3
 2) tcl8.3-dev
 3) tk8.3
 4) tk8.3-dev

no problems with 1,2,3 but when i come up to the last i receive error message like this:

 	Sorry, but the following packages have unmet dependencies:
 	tk8.3-dev: Depends: xlibs-dev but it is not going to be installed
 	E: Sorry, broken packages

 and prompts me again.

I tried also this:
	#apt-get install xlibs-dev

and i got the following:

	Sorry, but the following packages have unmet dependencies:
 	xlibs-dev: Depends: xlibs (= 4.3.0-0ds2.0.0woody2) but 4.1.0-16 is to be installed
 	E: Sorry, broken packages

Any idea regarding this problems?

Thank you in advance!

`apt-cache show xlibs` tells me the woody version of xlibs is 4.1.0-16woody5 - it looks like your system is a mix of stable and testing (or, a mix of stable and backported packages); You could try to downgrade but that would require apt pinning; (you may have a look at http://cert.uni-stuttgart.de/archive/debian/testing/2003/07/msg00039.html about downgrading to stable) You could also choose to use that same source where the xlibs package came from, using `apt-cache policy xlibs`, to install xlibs-dev A third option would be to upgrade the system to sarge; note that sarge is nearly stable, but it's not yet *really* stable (and might have more bugs, after all, those are still holding it to become stable, right?)



Reply to: