[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel installation woes on Athlon 1100: "hda: lost interrupt".

In message <3jrmy-7oO-49@gated-at.bofh.it>, Adam Funk <a24061@yahoo.com> writes
On Tuesday 04 January 2005 20:40, Joe wrote:

The motherboard is an ASRock K7S8X.  (I don't know what chips are on

I didn't see the beginning of this. I have one of these and I've yet
to see any Linux boot without noapic. Including Knoppix, and Woody on
2.4.18, and the current Sarge 2.6 and FC3.

It could be my combination of motherboard and Athlon processor.  The
2.4.23 kernel that worked without it was the 386 version, whereas the
2.4.26 and 2.4.27 kernels that work with naoapic are the k7 versions.

No, they were all stock versions. I've used K7 versions on other machines, but these were all out-of-the-box, presumably for 586 at most. I've never tried building an optimised Knoppix. The Woody was a boot-floppy version, the only 2.4 kernel supplied as standard. Sarge was the netinstall CD, FC3 as supplied on the Linux Format magazine DVD.

Possibly there's a BIOS fix by now, but it doesn't seem serious enough
to bother.

Is it a "defect" that requires the noapic option?

I think so. I don't believe a mere absence of a feature should stop a kernel booting, particularly a Knoppix one. I think it must be a hardware bug.

In fact a quick Google on 'k7s8x noapic bios' suggests that upgrading to version 2.30 of the BIOS will fix it. I'm still not sure I'll bother, I had a bad experience flashing a BIOS a few years ago.

Reply to: