[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: aic7xxx won't load, SOLVED?

I noticed that 2.6.10 actually contained a new aic79xxx driver which is working like magic at the moment. I managed to build a boot cd from this after quite a lot of work...

Later on I also noticed that the boot disks from http://wiki.osuosl.org/display/LNX/Debian+on+Dell+Servers would work as well for those RAID-cards. =(

Anyway, the new aic79xxx allows for HostRAID so I'm one happy camper at the moment – however it seems to break the e1000 module for the NIC's in the machine, or that just might be me not getting any sleep lately...

Thanks for your time!


On 03 jan 2005, at 15.49, Tim Kelley wrote:

On Thu, Dec 30, 2004 at 04:16:30PM +0100, Didde Brockman wrote:

After trying a stable install which of course could not find the
drive(s) I resorted to the Debian Installer which has helped in the
passed when I had to deal with hardware not supported by woody's boot
disks. Sarge seems to have the necessary modules (aic7xxx etc.) but
while it's "detecting hardware" it says that some of the modules failed
to load ? more specifically the aic7xxx, which of course results in no
disks being found either. I figured that I might be able to load it
manually but insmod simply returns an error from which I can tell
nothing... Just that it fails to load. This applies to both rc2 and the
newer daily builds...

The driver in the kernel does not work and never will, Red Hat patches
their RHEL 3 U3 kernel for this card. No other linux works with these
cards. To install debian on this machine you will need to build a
custom install cd with a kernel that can see this card .. which is
quite a process.

The hardware seems to be fine as I can install RH without a glitch and
it runs well, so I'm starting to wonder if this module might be broken
under sarge? Has this happened to anybody but me? I'd be very glad if
someone could point me into the right direction on this one as I am now
officially stuck...

Let me guess - RHEL 3 update 3?

Might mention that I also tried running linux26 off the Debian
Installer but with the same results...

For some reason the aic7xxx driver in the linux kernel tree is
ancient. If you download the source from adaptec, you get version
2.08. The version included with the kernel is like 1.3, even with
2.6. this doesn't appear to have changed at all from 2.4.18 or before,
which is a long time. I don't know why this is, but you might ask the
drivers maintainer.

Reply to: